2006年10月19日 07:40 by matsuu

こんばんわ。いろいろ自分なりに調べたのですが、手詰ま
りになってしまったので知恵を貸していただければと思い
ます。

経緯
 ウイルスソフト「F-secure Linux」をインストールす
 る際に環境変数 _POSIX2_VERSION を200111以下に
 行わないとインストールができません。

質問1
 環境変数 _POSIX2_VERSION を変更したいのですが、
 どのようにすればよいのでしょうか?

質問2
 調べた感じですと、この環境変数は重要な気がして変更
 することでシステム的に矛盾など発生しないのでしょう
 か?

環境
 x86
 GCC以外は、マスクかけずほぼ最新

以上、よろしくお願いします。

1: 口コミさん : 2006-10-22 06:29
インストーラが起動するGNUのツールが古い書式で起動されるために、
環境変数によって古い標準に合わせる必要なんだと思います。
なので、インストーラを
_POSIX2_VERSION=199209 ./name_of_installer
みたいな感じで起動すればよいかと。
これはインストーラの実行にのみ有効で、システムには影響を与えません。
2: 口コミさん : 2006-10-23 03:35
ドルチさん ありがとうございます。
無事インストールできました。
(1ヶ月かかった謎が解決できました。)
勉強になりました。

サイト内検索